Issue: RDS/Petroware customer issues printing to Ricoh printer

Date Documented: 26 Oct 2018



Symptoms / Error

  • Petroware customer on RDS has issues printing from reports in landscape mode. 

  • Printer being used is a Ricoh MP 2501

  • Easy Print drive being used.

  • Reports will not landscape correctly. Unable to get server to use RICOH drivers. Continually uses Easy Print.

Cause

  • There is some mention of RICOH printers not being supported on RDS with the Easy Print drivers

Fix

  • Disable "Use Remote Desktop Easy Print printer driver first"

  • This is located at Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Printer Rediection

  • Set to Disable. This will cause RICOH driver to be used first, Easy Print only if that fails.

Summary

  • This fix may be applicable to other printer issues. Although very few printers have issues with the Easy Print driver this still may be a valid troubleshooting step.